Degraded Performance and Page Load Failures

Incident Report for Omnea

Resolved

All pages are showing a return to full performance. This incident is now resolved.
Posted Aug 19, 2025 - 19:10 BST

Monitoring

Performance with the third-party provider has been resolved. We're monitoring the Omnea platform performance to ensure the fix reflects on all pages.
Posted Aug 19, 2025 - 16:37 BST

Identified

We have identified degraded performance with a third-party database provider that is causing some app pages to load more slowly or timeout entirely depending on network speed.
Posted Aug 19, 2025 - 15:46 BST
This incident affected: Omnea Platform.