Downstream SSO provider issue may cause certain users to have issues logging in

Incident Report for Omnea

Resolved

The downstream AWS Cloudfront outage has been marked as resolved. Monitoring confirmed no further effect on the Omnea platform.
Posted Jul 16, 2026 - 14:44 BST

Monitoring

We've seen no further issues and confirmed Omnea can withstand further degradation to the AWS VPC Origins feature that is currently undergoing an outage.

We've also re-routed login to avoid the degraded downstream areas so fewer users should see any IdP issues either. If you still experience login issues please reach out to support in-app (not gated by login).
Posted Jul 16, 2026 - 11:21 BST

Update

At present, we've confirmed that the AWS Cloudfront global outage is not affecting core Omnea services outside of certain IdP login issues. Our team is continuing to monitor the downstream status in case of further degradation.
Posted Jul 16, 2026 - 10:26 BST

Identified

The downstream provider issue is being caused by a further downstream AWS Cloudfront outage causing widespread internet outages across the globe. Our team is monitoring those incidents to minimise effect on Omnea services.
Posted Jul 16, 2026 - 10:00 BST

Investigating

A downstream provider (https://status.workos.com/) are seeing elevated error rates. We are investigating if any Omnea users will see knock on effects. Exact impact will depend on login method and IdP used.
Posted Jul 16, 2026 - 09:47 BST
This incident affected: Omnea Platform.