Documents timing out during upload and opening

Incident Report for Omnea

Resolved

Confirmed as resolved.
Posted Jan 14, 2026 - 17:10 GMT

Monitoring

We've identified an issue when uploading or downloading certain documents from the platform. A fix is already deployed. We're monitoring for repeats.
Posted Jan 14, 2026 - 16:52 GMT
This incident affected: Omnea Platform.