Degraded loading speeds

Incident Report for Omnea

Resolved

Issue resolved by fixing a parallel query conflict.
Posted May 26, 2026 - 17:16 BST

Investigating

Some pages are showing degraded loading speeds which is preventing some workflows and tasks from loading. We're identifying the root cause to rectify quickly.
Posted May 26, 2026 - 17:11 BST
This incident affected: Omnea Platform.