We experienced an issue earlier where emails were not being sent or were only delivered intermittently. The issue has now been identified and resolved. Email delivery is back to normal.
We’re continuing to monitor to ensure full stability. Thank you for your patience.
Posted May 15, 2025 - 12:06 BST
Update
We are continuing to investigate this issue.
Posted May 15, 2025 - 11:34 BST
Investigating
We are currently investigating an issue where emails are not being sent or are only being delivered intermittently. This may affect transactional and notification emails across our platform. We will provide an update as soon as we have more information.