Escalated volume of page load errors

Incident Report for Omnea

Resolved

Issue has been resolved. The errors were related to a small selection of IP addresses - no discernible external impact.
Posted Feb 26, 2026 - 12:46 GMT

Investigating

We are currently investigating the cause of this issue.
Posted Feb 26, 2026 - 12:45 GMT
This incident affected: Omnea Platform.